Disruption of Paketsteuerung

Minor incident Parcel Germany (DHL) Parcel Management
2023-08-09 13:56 CEST · 14 minutes

Updates

Resolved

The service is fully usable again.

August 9, 2023 · 14:11 CEST
Issue

At the moment there may be interruptions of the service. We are working hard to fix it and we apologize for the inconvenience.

August 9, 2023 · 13:56 CEST

← Back