Disruption of Paketsteuerung

Minor incident Parcel Germany (DHL) Parcel Management
2023-07-29 10:35 CEST · 1 hour, 10 minutes

Updates

Resolved

The service is fully usable again.

July 29, 2023 · 11:46 CEST
Issue

At the moment there may be interruptions of the service. We are working hard to fix it and we apologize for the inconvenience.

July 29, 2023 · 10:35 CEST

← Back