Disruption of Paketsteuerung

Minor incident Parcel Germany (DHL) Parcel Management
2023-07-24 22:19 CEST · 27 minutes

Updates

Resolved

The service is fully usable again.

July 24, 2023 · 22:47 CEST
Issue

At the moment there may be interruptions of the service. We are working hard to fix it and we apologize for the inconvenience.

July 24, 2023 · 22:19 CEST

← Back