[Service] - Potential disruptions

Minor incident Post Germany (German Mail) Dialogmarketing Suite Dispatch Preparation API
2026-01-20 16:07 CET · 1 week, 1 day, 18 hours, 41 minutes

Updates

Resolved

The service is fully usable again.

January 29, 2026 · 10:48 CET
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

January 20, 2026 · 16:07 CET

← Back