[Service] - Potential disruptions

Major incident Post Germany (German Mail) Dialogmarketing Suite Dispatch Preparation API
2025-11-21 15:52 CET · 1 hour, 5 minutes

Updates

Resolved

The service is fully usable again.

November 21, 2025 · 16:57 CET
Issue

There are service disruptions at the moment. We are working hard to rectify this and apologize for the inconvenience.

November 21, 2025 · 15:52 CET

← Back