[AM.GK-P] - Short-term maintenance work with disruption to services. from 2025-10-01 07:15 CEST to 2025-10-01 08:30 CEST

Scheduled maintenance Post Germany (German Mail) Ordermanagement AM.GK-P
2025-10-01 07:15 CEST · 1 hour, 15 minutes

Updates

Resolved

This maintenance has been concluded as planned.

October 1, 2025 · 08:30 CEST
Resolved

This maintenance has been concluded as planned.

October 1, 2025 · 08:00 CEST
Scheduled

AM.GKP - Maintenance from 2025-10-01 06:00 to 2025-10-01 08:00

October 1, 2025 · 07:11 CEST

← Back