AM.exchange – synchronous communication - Potential disruptions

Minor incident Post Germany (German Mail) Ordermanagement AM.exchange – synchronous communication
2025-09-15 07:05 CEST · 18 minutes, 1 second

Updates

Resolved

The service is fully usable again.

September 15, 2025 · 07:23 CEST
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

September 15, 2025 · 07:05 CEST

← Back