AM..portal - Potential disruptions

Minor incident Post Germany (German Mail) Ordermanagement AM.portal (Read-only)
2025-08-18 10:15 CEST · 51 minutes

Updates

Resolved

The service is fully usable again.

August 18, 2025 · 11:06 CEST
Issue

Due to a technical malfunction, the billing centre is currently unavailable. We are working hard to rectify this and apologise for the inconvenience.

August 18, 2025 · 10:15 CEST

← Back