AM.exchange – synchronous communication - Potential disruptions

Major incident Post Germany (German Mail) Ordermanagement AM.exchange – synchronous communication
2025-03-13 15:57 · 1 hour, 15 minutes

Updates

Times are shown in Africa/Abidjan timezone
Resolved

The service is fully usable again.

March 13, 2025 · 17:12
Escalate

Currently, the service is not available due to technical reasons. The responsible departments are already working on the analysis and elimination. We regret any inconvenience this may cause.

March 13, 2025 · 16:46
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

March 13, 2025 · 15:57

← Back