Returns international (cig.dhl.de) - Potential disruptions

Minor incident Parcel Germany (DHL) Returns API Returns international (cig.dhl.de)
2025-03-10 16:33 CET · 23 minutes

Updates

Resolved

The service is fully usable again.

March 10, 2025 · 16:56 CET
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

March 10, 2025 · 16:33 CET

← Back