Returns international (api-eu.dhl.com) - Potential disruptions

Minor incident Parcel Germany (DHL) Returns API Returns international (api-eu.dhl.com)
2025-02-28 17:09 CET · 17 minutes

Updates

Resolved

The service is fully usable again.

February 28, 2025 · 17:27 CET
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

February 28, 2025 · 17:09 CET

← Back