Ordermanagment - Potential disruptions

Minor incident Post Germany (German Mail) Ordermanagement AM.portal (Read-only) AM.GK-P AM.exchange – synchronous communication
2025-02-19 09:38 CET · 2 hours, 53 minutes

Updates

Resolved

The service is fully usable again.

February 19, 2025 · 12:31 CET
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

February 19, 2025 · 09:38 CET

← Back