[Service] - Potential disruptions

Minor incident Post Germany (German Mail) Ordermanagement AM.GK-P
2025-02-18 14:59 CET · 2 hours, 31 minutes

Updates

Resolved

The service is fully usable again.

February 18, 2025 · 17:29 CET
Investigating

There are currently longer response times when creating or processing orders. We are working hard to rectify the problem. We apologise for the inconvenience.

February 18, 2025 · 14:59 CET

← Back