AM.exchange - Potential disruptions

Minor incident Post Germany (German Mail) Ordermanagement AM.exchange – synchronous communication
2025-02-18 13:12 CET · 4 hours, 17 minutes

Updates

Resolved

The service is fully usable again.

February 18, 2025 · 17:29 CET
Investigating

There are currently longer response times when creating or processing orders. We are working hard to rectify the problem. We apologise for the inconvenience.

February 18, 2025 · 15:08 CET
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

February 18, 2025 · 13:12 CET

← Back