Returns international (api-eu.dhl.com) - Potential disruptions
Minor incident
Parcel Germany (DHL)
Returns API
Returns international (api-eu.dhl.com)
2024-11-26 05:15 CET
· 29 minutes
Updates
Resolved
November 26, 2024 · 05:44 CET
Unfortunately, this is a false alarm, and planned maintenance is currently taking place. We apologize
Issue
November 26, 2024 · 05:15 CET
There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.
← Back