Shipping API - Deutsche Post International - Potential disruptions

Minor incident Deutsche Post International Shipping API - Deutsche Post International
2024-09-09 12:14 CEST · 7 minutes

Updates

Resolved

The service is fully usable again.

September 9, 2024 · 12:21 CEST
Resolved

The service is fully usable again.

September 9, 2024 · 12:21 CEST
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

September 9, 2024 · 12:14 CEST

← Back