AM.exchange – synchronous communication - Potential disruptions

Minor incident Post Germany (German Mail) Ordermanagement AM.exchange – synchronous communication
2024-07-26 00:23 CEST · 17 minutes

Updates

Resolved

The service is fully usable again.

July 26, 2024 · 00:40 CEST
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

July 26, 2024 · 00:23 CEST

← Back