Returns international (cig.dhl.de) - Potential disruptions

Minor incident Parcel Germany (DHL) Returns API Returns international (api-eu.dhl.com) Returns international (cig.dhl.de)
2024-07-25 23:13 CEST · 16 minutes

Updates

Resolved

The service is fully usable again.

July 25, 2024 · 23:29 CEST
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

July 25, 2024 · 23:13 CEST

← Back