Customer Portal - Deutsche Post International - Potential disruptions

Minor incident Deutsche Post International Customer Portal - Deutsche Post International
2024-04-11 00:36 CEST · 5 minutes

Updates

Resolved

The service is fully usable again.

April 11, 2024 · 00:42 CEST
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

April 11, 2024 · 00:36 CEST

← Back