AM.portal - Potential disruptions

Minor incident Post Germany (German Mail) Ordermanagement AM.portal
2024-04-10 08:00 CEST · 8 hours, 2 minutes

Updates

Resolved

The service is fully usable again.

April 10, 2024 · 16:01 CEST
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

April 10, 2024 · 11:55 CEST

← Back