Returns international (cig.dhl.de) - Potential disruptions

Minor incident Parcel Germany (DHL) Returns Returns international (cig.dhl.de)
2024-03-20 05:28 CEST · 15 minutes

Updates

Resolved

The service is fully usable again.

March 20, 2024 · 05:43 CEST
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

March 20, 2024 · 05:28 CEST

← Back