Returns international (cig.dhl.de) - Potential disruptions

Minor incident Parcel Germany (DHL) Returns Returns international (cig.dhl.de)
2024-03-12 14:42 CEST · 19 minutes

Updates

Resolved

The service is fully usable again.

March 12, 2024 · 15:02 CEST
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

March 12, 2024 · 14:42 CEST

← Back