Tracking Services - Cross Border - Potential disruptions

Minor incident Deutsche Post International Tracking API - Deutsche Post International
2024-03-11 18:17 CEST · 5 minutes

Updates

Resolved

The service is fully usable again.

March 11, 2024 · 18:22 CEST
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

March 11, 2024 · 18:17 CEST

← Back