Disruption of Customer Portal - Deutsche Post International

Minor incident Deutsche Post International Customer Portal - Deutsche Post International
2024-01-16 11:43 CEST · 3 minutes

Updates

Resolved

The service is fully usable again.

January 16, 2024 · 11:46 CEST
Issue

At the moment there may be interruptions of the service. We are working hard to fix it and we apologize for the inconvenience.

January 16, 2024 · 11:43 CEST

← Back