Disruption of Returns international (cig.dhl.de)

Minor incident Parcel Germany (DHL) Returns Returns international (cig.dhl.de)
2023-12-18 11:59 CEST · 30 minutes

Updates

Resolved

The service is fully usable again.

December 18, 2023 · 12:29 CEST
Issue

At the moment there may be interruptions of the service. We are working hard to fix it and we apologize for the inconvenience.

December 18, 2023 · 11:59 CEST

← Back