Disruption of Returns international (cig.dhl.de)

Minor incident Parcel Germany (DHL) Returns Returns international (cig.dhl.de)
2023-11-28 05:11 CEST · 51 minutes

Updates

Resolved

The service is fully usable again.

November 28, 2023 · 06:02 CEST
Issue

At the moment there may be interruptions of the service. We are working hard to fix it and we apologize for the inconvenience.

November 28, 2023 · 05:11 CEST

← Back