Disruption of Shipping Services - Internetmarke

Minor incident Post Germany (German Mail) Internetmarke Shipping Services - Internetmarke
2023-10-30 02:45 CEST · 25 minutes

Updates

Resolved

The service is fully usable again.

October 30, 2023 · 03:10 CEST
Issue

At the moment there may be interruptions of the service. We are working hard to fix it and we apologize for the inconvenience.

October 30, 2023 · 02:45 CEST

← Back