Customer Portal - Deutsche Post International - Potential disruptions

Minor incident Deutsche Post International Customer Portal - Deutsche Post International
2025-04-05 01:11 CEST · 15 minutes

Updates

Resolved

The service is fully usable again.

April 5, 2025 · 01:27 CEST
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

April 5, 2025 · 01:11 CEST

← Back