Shipping API - Deutsche Post International - Potential disruptions

Minor incident Deutsche Post International Shipping API - Deutsche Post International
2025-02-04 19:13 CET · 5 minutes

Updates

Resolved

The service is fully usable again.

February 4, 2025 · 19:18 CET
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

February 4, 2025 · 19:13 CET

← Back