Tracking API - Deutsche Post International - Potential disruptions

Minor incident Deutsche Post International Tracking API - Deutsche Post International
2025-01-26 08:07 CET · 39 minutes

Updates

Resolved

The service is fully usable again.

January 26, 2025 · 08:47 CET
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

January 26, 2025 · 08:07 CET

← Back