Returns international (cig.dhl.de) - Potential disruptions

Minor incident Parcel Germany (DHL) Returns API Returns international (cig.dhl.de)
2025-01-25 09:43 CET · 37 minutes

Updates

Resolved

The service is fully usable again.

January 25, 2025 · 10:21 CET
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

January 25, 2025 · 09:43 CET

← Back