AM.portal - Potential disruptions

Minor incident Post Germany (German Mail) Ordermanagement AM.portal (Read-only)
2025-01-02 00:00 CET · 6 days, 16 hours, 22 minutes

Updates

Resolved

The tracking information for pallets is now fully available again.

January 8, 2025 · 16:18 CET
Issue

Due to a technical problem, the tracking information for pallets is not available for orders from the postal delivery date of 02.01.2025.
We are working hard to rectify this and apologize for the inconvenience.

January 8, 2025 · 09:43 CET

← Back