Returns international (cig.dhl.de) - Potential disruptions

Minor incident Parcel Germany (DHL) Returns API Returns international (cig.dhl.de)
2024-06-25 10:05 CEST · 23 minutes, 1 second

Updates

Resolved

The service is fully usable again.

June 25, 2024 · 10:28 CEST
Resolved

The service is fully usable again.

June 25, 2024 · 10:28 CEST
Issue

There may be service disruptions at the moment. We are working hard to rectify this and apologise for the inconvenience.

June 25, 2024 · 10:05 CEST

← Back